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Best Practices for Running QuickBooks in a Multi-User Environment 

 

There are dozens of issues that can lead to QuickBooks freezing and locking out users which can be 

horribly frustrating in a multi-user and/or hosted environment.  Some cases are real “freezes” and some 

cases just “look” like freezes.   The software, while being a great accounting system, repeatedly receives 

poor marks for reliability in a networked environment.   Unfortunately, the answer from tech support is 

too often “do a repair install” or “reboot” which does not always resolve the issue and is often 

disruptive. Also, as a trained software engineer, I just detest this answer. 

Turn Key Office has prepared this guide to best practices which can eliminate a high percentage of these 

issues.   A little understanding of some of the limitations and assumptions Intuit developers made goes a 

long way toward a more pleasant overall multi-user experience.  
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Avoid Excessive Launches 
A leading cause of QuickBooks hanging for large files and/or multiple users is a user clicking to launch 

the application several times in quick succession.  The larger the file, the more users, and the more 

inefficient the startup preferences are set, the longer it will take to open the database.   If you launch 

QuickBooks more than twice, it has a high propensity to hang. In many years of seeing and researching 

this problem, I have yet to find a Windows solution or an Intuit solution to the issue.  If you suspect this 

is one of your causes, simply go to task manager and check how many instances of “QBW32.exe” you 

have running in the processes tab. If you have more than two, it is probably hung. Sometimes it will 

rectify itself. 

So… get a cup of coffee.  Seriously. Wait five more minutes, because killing a task while it is performing a 

data write to the file can result in data file damage and should be used as a last resort. 

However, sometimes there is no other way out.  On a regular desktop, click Ctrl+Alt+Del to look at the 

task manager. On a remote desktop, place your mouse in the bottom gray bar of the remote desktop 

screen, right-click the mouse button, and click “Start Task Manager” 

In either case, you should only have one instance running. If you have more than one and it has been 

SEVERAL MINUTES since you first launched QuickBooks and gotten your cup of coffee, and nothing is on 

the screen or minimized below, kill the task, wait a few more minutes, then try launching again – once.  

You can kill the task by right–clicking on the task and selecting End Process. 
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Maximize Efficiency of Launching QuickBooks with Preferences 
Configure your user preferences to be as efficient as possible when opening and closing this large 

database of information.  This means being aware of certain features in QuickBooks that are fine for 

smaller files and/or fewer users but become problematic in larger organizations.  Because these 

preferences are set inside the software, and sometimes on a user-by-user basis, network administrators 

may be unfamiliar with them, may not have access to them, and be unable to assist. 

 

Turn OFF automatic updates.  
While it may seem counter-intuitive, it is better to have the QuickBooks administrator check for updates 

in QuickBooks and apply them during “quiet time.”  QuickBooks has no idea which users have 

administrative privileges to install updates, and consequently tries to check and install updates when 

every user opens the file.  Depending on UAC permission settings for that user, there may be an upgrade 

dialogue box suppressed and the software just appears to hang.  To disable automatic updates, first 

open your company file. Navigate to the HELP menu -> Update Quickbooks Desktop and click the 

“options” tab and turn off automatic updates.  This must be done once for each individual company file. 

The corollary to this is to make SURE that the hosting server instance of QuickBooks as well as each 

users’ version of QuickBooks are always updated and patched at the same time and are on the same 

version.  Different instances of the software accessing the same data file can also lead to hanging 

symptoms.  It is extremely common for us to troubleshoot user software installations having a different 

patch level than the server software instance where the file is actually located and shared. 
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Don’t Save the Desktop 
For some odious reason, saving the desktop is the default configuration for every QuickBooks user. This 

means: every time a user opens or closes the file, every single report configuration and window open in 

their QuickBooks desktop will be written to disk when closed, and re-populated with new data when 

opened.  This really serves no useful purpose than I can think of.  To change this preference, you will 

need to log in as EACH user of EVERY file and go to Edit->Preferences->Desktop View and click Don’t 

Save the Desktop.   

 

 

Maximize Intervals between Search Automatic Update 
QuickBooks text search functionality is updated on a periodic basis with any new data that is posted.   

This is almost like a Google search inside of QuickBooks that goes beyond the traditional “find” 

capabilities.  Intuit recommends, and I agree, to set this interval to the maximum amount of time – 60 

minutes. If newer versions allow you to update less frequently, I’d be inclined to go longer.  To update 

this preference, open EACH company file as Admin in Single User mode, go to Edit->Preferences->Search 

and change the settings as shown.   
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Disable QuickBooks Messenger 
Another “too cool for itself” app that I have a “love/hate” relationship is QuickBooks Messenger. 

Sometimes it is great, especially in 17.0 when you have the option to log out users who are preventing 

you from going into single user mode.   However, too often it hangs QuickBooks and doesn’t allow the 

file to fully close.   A common error message you will get just when you try to switch to single user mode 

is “can’t login to single user mode, another user (Admin – you) has just logged in.”  Of course, it’s not the 

other you… It’s just you. Alone. But 

now QuickBooks thinks its two of 

you. And… then QuickBooks hangs…  

And, killing the messenger task just 

spawns multiple additional tasks, 

like the fabled hydra that won’t die. 

Just not worth the benefits in my 

opinion.  I recommend disabling it.  

Note – you will have to be in multi 

user mode to see this option, but 

simply navigate to File->Utilities and 

Disable it.  This must be done in 

each individual company file.  
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Keep QuickBooks Running – Don’t. 
Another feature the Intuit developers thought (I presume) might make QuickBooks more responsive is 

just to simply… never… close it.  Ghastly idea in my opinion, especially when you’re working with plug 

ins and third party apps that need to launch QuickBooks from the outside.  Hard to get a clean launch if 

it’s already half-running. I also theorize that it conflicts with itself and the software’s ability to recognize 

a “new launch” for purposes of installing updates.  I recommend disabling this.  In Enterprise 16 and 

lower, you can find the preference in Edit->Preferences->General in the My Preferences Tab.  Yes… this 

means you need to change this preference for EVERY file and for EVERY user.  

As an extra bonus… when you do change it, do yourself a favor and close the file and reopen it to make 

sure it actually changed. Don’t be surprised if the preference hasn’t changed itself, in which case you 

may need to repair install QuickBooks or make sure your QBW.INI file isn’t set to read only. 

 

 

 

In Enterprise 17.0 this problematic feature is changed so that it is at least a company preference, but it 

looks like this…  I think a developer fought really hard to keep the feature in there so that when users log 

off, they can actually remain logged in for two solid days… Still don’t quite know what that is supposed 

to do, but in network administrator land, we like things to close when they’re closed . I recommend 

changing this preference to log them off when they actually log off.   
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Check for Hidden Dialogue Boxes 
In remote desktop applications or environments with multiple monitors, sometimes the screen (both 

inside and outside of QuickBooks) gets confused and you may have a dialog box waiting for your input 

that you just can’t see.  This has tripped users up before so it’s worthy to mention! You can resize your 

desktop screen by doing the following: 

 

1). Hit ESC a few times in a row to close the dialog box 

2). Inside QuickBooks, select Windows->Close All 

3). Once all windows are closed press CTRL+SHIFT+C 

4). Select File->exit to close quickbooks 

5). Open QuickBooks and login to your company file.  

 

Avoid Damaging Your File 
A file that is damaged or has many fragments is harder for QuickBooks to open and can lead to further 

damage.  Perform regular maintenance on the file and adhere to the tips below to avoid damage.  If you 

suspect data file damage, refer to our other article on our website entitled Repairing a Damaged File for 

further help. 
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My Fab Five Quick Tips: 
Do not use the Admin login for routine data entry. 
Encryption errors, though rare, may be unrepairable 
if they occur in the Admin account. 
 
Educate users to NOT close QuickBooks using the 
“X” in the upper right screen of the QuickBooks 
window. This is actually a “force close” of the 
software and has been linked to damaged files.   
Users should close QuickBooks by going to the 
FileClose Company/Log Off or File->Exit menu.   
 
Re-sort Lists and perform a full back-up in single user 
mode which will Verify the data integrity instead of 
just doing the backup alone.  Backups done while in 
multi-user mode will not verify the data. 
 
Never perform a software version upgrade or a 
condense on a file with data errors! 
 
Do not allow inventory to go to negative on-hand 
quantities. 

 
 

 

Properly Configure QuickBooks for Multi User Access (for Admins) 
QuickBooks installation wizards don’t always have proper permissions to configure network or folder 

access properly or efficiently, for multiple user access.  Additionally, firewalls and anti-virus programs 

are notorious for blocking traffic necessary to manage multi user access operations.  Here are a few 

quick tips to aid network administrators in installing and configuring QuickBooks Enterprise for multi-

user access.  

 

Startup Services 
After installation (or a repair install) review msconfig startup settings and de-select excessive services 

which may take QuickBooks longer to open. 
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Services Properties 
On the server where the QuickBooks file is housed, check that the services that are important to manage 

multi-user access are configured properly.  Specifically, the services below should be configured for 

automatic startup, configured to Log On as the local system account without interacting with the 

desktop, and automatically recover on failures. 
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Avoid Competition for Hosting Multi User Access 
Also, make sure that only one instance of QuickBooks is “hosting multi user access.”  Each user that logs 

into the file can accidentally select “Start Hosting Multi User Access” in the File menu, not realizing what 

this selection does.  It will have the effect of competing with the server location which is hosting multi 

user access.   If they have selected this feature, make sure that instance of QuickBooks software selects 

the option shown below to “Stop Hosting Multi User Access” otherwise no one else will be able to 

reliably log into the QuickBooks file in multi user mode. 
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Folder permissions 
All users – including the QuickBooks “user” account created during installation to control multi user 

access, must have full permission to access the folder where the QuickBooks data file *.QBW is located. 

Often, the QBDataServiceUserXX doesn’t manage to grab full permission over the QuickBooks data file 

folder and inconsistent multi-user behavior will be the result.  Especially remember to check this after an 

upgrade, because there will be a QBDataServiceUserXX + 1 that will need permissions. 

 

Check Firewall Ports 
When the database server manager indicates it has a firewall problem, don’t always believe it. 

Enterprise 15.0 has an undocumented bug that indicates a firewall problem when it doesn’t.  You can try 

disabling firewalls entirely and/or reviewing logs that indicate no packets were blocked, and you’ll still 

get the same erroneous message.   However, if you DO need to manually configure ports to allow 

QuickBooks multi user services to connect, the following instructions are lifted from Intuit’s community 

website and should help. 

 

Windows 10, Server 2008, Server 2012 

1. Select Start menu and enter the word: firewall. 
2. Select Windows Firewall. 
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3. On the right-hand side, select Advanced Settings. 
4. Right-click Inbound Rules and select New Rule. 
5. Select Port and select Next. 
6. Make sure TCP is selected and type in specific ports needed for your QuickBooks year version: (if 

you have multiple years of QuickBooks Desktop installed or will be using, you will need to add 
each year's ports as well in this format: 8019, XXXXX, XXXXX, XXXXX, XXXXX).  

o QuickBooks Desktop 2018: 8019, 56728, 55378-55382 
o QuickBooks Desktop 2017: 8019, 56727, 55373-55377 
o QuickBooks Desktop 2016: 8019, 56726, 55368-55372 
o QuickBooks Desktop 2015: 8019, 56725, 55363-55367 

7. Select Next and make sure Allow the Connection is selected, then select Next again. 
8. Select Next again and give the rule a name, such as QBPorts. Select Finish when done. 
9. Repeat the steps above for the Outbound Rules (for step 4 inbound rules, choose Outbound 

Rules). 
10. Try opening QuickBooks Desktop again in multi-user mode or over your network to see if the 

issue has been resolved. 

Additional Support 
Turn Key Office would be pleased to provide additional support if needed or if you are continuing to 

have problems with QuickBooks.  Feel free to contact us at info@turnkeyoffice.net or visit us on our 

website www.TurnKeyOffice.net  
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